Why am I missing data? (SS 7.0 + ASP) 
Author Message
 Why am I missing data? (SS 7.0 + ASP)

Hello,

Please point me to the correct newsgroup or other resources if this
isn't the right one.

Using SQL Server 7.0 on our ISP's shared server environment using NT
4.0. Using ASP to create SQL statements to insert data into a table for
a web-based data collection application. Have error trapping enabled so
that if an error occurs it tries to rerun the query. It also writes the
error number, sql statement and other info to an error table. If I get
more than a handful of simultaneous users then I start getting
deadlocks, which is the most typical error.

A typical table has an id column and then anywhere from 5 to 500 data
columns. Each column is typically defined as a 3 nvarchar. Users go
through a bunch of pages selecting radio buttons and it writes the 3
alphadigit of the selected button to the database. One update per page.
On a few records (maybe 1/2 to 1 percent) I noticed that a bunch of data
is missing. One time out of 1000 records 10 of them were all missing
data in the first half of of the columns. Other records were complete.
No errors were recorded in the error table. Behaviour happens for both
small and large tables.

Typical update goes like this. err_check is a sub that

conn_str="driver={SQL
Server};server=xxx.xxx.xxx.xxx;database=db_name;uid=login;pwd=password"
sql="UPDATE data_table SET q1='ab1' WHERE id=1234"
set conn = server.createobject("ADODB.Connection")
call err_check(login_id,q_num,conn,sql,"store_data_1")
conn.open conn_str
call err_check(login_id,q_num,conn,sql,"store_data_2")
conn.execute sql , , &H00000080
call err_check(login_id,q_num,conn,sql,"store_data_3")
conn.close
set conn=nothing

Any clues as to why I'm mysteriously missing data would be greatly
appreciated.
Thanks.



Wed, 30 Jun 2004 03:53:30 GMT
 Why am I missing data? (SS 7.0 + ASP)

Hello,

Please point me to the correct newsgroup or other resources if this
isn't the right one.

Using SQL Server 7.0 on our ISP's shared server environment using NT
4.0. Using ASP to create SQL statements to insert data into a table for
a web-based data collection application. Have error trapping enabled so
that if an error occurs it tries to rerun the query. It also writes the
error number, sql statement and other info to an error table. If I get
more than a handful of simultaneous users then I start getting
deadlocks, which is the most typical error.

A typical table has an id column and then anywhere from 5 to 500 data
columns. Each column is typically defined as a 3 nvarchar. Users go
through a bunch of pages selecting radio buttons and it writes the 3
alphadigit of the selected button to the database. One update per page.
On a few records (maybe 1/2 to 1 percent) I noticed that a bunch of data
is missing. One time out of 1000 records 10 of them were all missing
data in the first half of of the columns. Other records were complete.
No errors were recorded in the error table. Behaviour happens for both
small and large tables.

Typical update goes like this. err_check is a sub that

conn_str="driver={SQL
Server};server=xxx.xxx.xxx.xxx;database=db_name;uid=login;pwd=password"
sql="UPDATE data_table SET q1='ab1' WHERE id=1234"
set conn = server.createobject("ADODB.Connection")
call err_check(login_id,q_num,conn,sql,"store_data_1")
conn.open conn_str
call err_check(login_id,q_num,conn,sql,"store_data_2")
conn.execute sql , , &H00000080
call err_check(login_id,q_num,conn,sql,"store_data_3")
conn.close
set conn=nothing

Any clues as to why I'm mysteriously missing data would be greatly
appreciated.
Thanks.



Wed, 30 Jun 2004 03:59:02 GMT
 Why am I missing data? (SS 7.0 + ASP)
Still have no clue on this - can anyone help out. Please please please? ;)
Quote:

> Hello,

> Please point me to the correct newsgroup or other resources if this
> isn't the right one.

> Using SQL Server 7.0 on our ISP's shared server environment using NT
> 4.0. Using ASP to create SQL statements to insert data into a table for
> a web-based data collection application. Have error trapping enabled so
> that if an error occurs it tries to rerun the query. It also writes the
> error number, sql statement and other info to an error table. If I get
> more than a handful of simultaneous users then I start getting
> deadlocks, which is the most typical error.

> A typical table has an id column and then anywhere from 5 to 500 data
> columns. Each column is typically defined as a 3 nvarchar. Users go
> through a bunch of pages selecting radio buttons and it writes the 3
> alphadigit of the selected button to the database. One update per page.
> On a few records (maybe 1/2 to 1 percent) I noticed that a bunch of data
> is missing. One time out of 1000 records 10 of them were all missing
> data in the first half of of the columns. Other records were complete.
> No errors were recorded in the error table. Behaviour happens for both
> small and large tables.

> Typical update goes like this. err_check is a sub that

> conn_str="driver={SQL
> Server};server=xxx.xxx.xxx.xxx;database=db_name;uid=login;pwd=password"
> sql="UPDATE data_table SET q1='ab1' WHERE id=1234"
> set conn = server.createobject("ADODB.Connection")
> call err_check(login_id,q_num,conn,sql,"store_data_1")
> conn.open conn_str
> call err_check(login_id,q_num,conn,sql,"store_data_2")
> conn.execute sql , , &H00000080
> call err_check(login_id,q_num,conn,sql,"store_data_3")
> conn.close
> set conn=nothing

> Any clues as to why I'm mysteriously missing data would be greatly
> appreciated.
> Thanks.



Mon, 26 Jul 2004 09:05:34 GMT
 
 [ 3 post ] 

 Relevant Pages 

1. What am I missing in Data Report SHOW?

2. Convert mm/dd/yyyy hh:mm:ss AM/PM to mm/dd/yyyy format

3. Display Time Only (hh:mm:ss AM - format)

4. Save time in hh:mm:ss AM/PM format

5. Save time in hh:mm:ss AM/PM format

6. Why I miss Data Bound Grid control?

7. ASP and RPC -- SS 6.5

8. Transfer data from SQL 7.0 to SQL 2000 missing identity property

9. Poor concurrency -- why is SS locking rows?

10. Wrong Data returned from MS SQL 7.0 using ASP/ADO

11. Wrong Data returned from SQL 7.0 using ASP/ADO

12. Wrong Data returned from SQL 7.0 using ASP/ADO


 
Powered by phpBB® Forum Software