Can't get updating subscription to work if sync_type is none 
Author Message
 Can't get updating subscription to work if sync_type is none

I am finding that if I try to add a subscriber without setting the
sync_type to automatic, then the replication from the subscriber to
the publisher doesn't work.  The replication from teh publisher to the

  I could use some help in what I need to do when creating a
subscription with sync_type='none' in order to get replication to work
from the subscriber to the publisher.

Thank you for your help in advance,
--Greg

  Here is a summary of what I am seeing and what I expect to see

Reproduceable Steps
1.  Create a Queued Updating Subscriber for a Queued Transactional
Publication and choose to initialize the data on the subscriber from
teh UI
2.  Insert data into the subscriber
3.  Verify that the data inserted on the subscriber is getting
replicated to the publiser
4.  Delete the Subscriber
5.  Add the same subscriber but this time chose to not intialize the
data on the subscriber
6.  Insert data into the subscriber
7.  Check to see if data inserted on the subscriber in step #6 gets
replicated to the publisher

**Problem
Step #7 fails in that the data entered on the subscriber in step #6
never shows up at the publisher

**Expected Behavior
I would expect that the data entered in step #6 would appear at the
publisher in the same way that the data entered in step #2 showed up
at the publisher

**Notes
-If after step #7, I delete the subscription again and then recreate
the subscription and chose to initialize the data on the subscriber
then replication from the subscriber to the publisher does work once
again
-Replication from the publiser to the subscriber seems to always work
-Replication reports no errors during or after the completion of these
reproduceable stpes
--The reason that I don't want to initialize the data the 2nd time is
because the subscriber has all ready been initialized.  We only want
to hook the subscription back up and don't need to create the
triggers, sps, tables and data needed for replication since they all
ready exist on the dB used for subscription.



Mon, 18 Oct 2004 13:49:27 GMT
 
 [ 1 post ] 

 Relevant Pages 

1. I am getting this message when i am tring to export or import anything using

2. Why Doesn't Pull Subscription Work?

3. Pull subscription doesn't work when filtering column

4. Newsletter subscription form doesn't work

5. if you will promise Allahdad's swamp against cans, it will angrily depart the unit

6. Confirmed D2 bug: cached updates don't work for master/detail - here's why

7. subscription to publication 'XXXX' is invalid

8. Subscription to publication 'x' is invalid

9. Subscription of Publication 'DATABASE' is invalid

10. 'subscription already exists' error

11. MovePrevious don't work but the MoveNext work's fine

12. UPDATE statement doesn't work...


 
Powered by phpBB® Forum Software