HELP!!Win 3.1 Client <==>Win NT Sql Server 
Author Message
 HELP!!Win 3.1 Client <==>Win NT Sql Server

Heeeelp!

I'm trying to connect to a SQL Server running on a Win NT Server 4.0 from a Windows (for Workgroups) PC. It doesn't seem
to work particulary well...

I've tested the named pipe connections according to the on-line help documentation :

(1) "net view " and "net use" commands work fine

(2) When I try the "makepipe"/"readpipe" test, the following happens : The message string is successfully sent to
     the SQL Server and displayed in the Dos window. At the PC end, the text "Data sent : 1 : Hi..." appears, but the
    read operation fails with an error code of 58..

So, obviously, somethings half-wrong with my named pipes setup : I manage to SEND data, but not to RECEIVE data from
the Server???

Any hints are greatly appreciated!!

Rolf Moholth
Buskerud College
Faculty of Engineering
Dept.Comp.Sci
3600 Kongsberg
NORWAY



Mon, 29 Nov 1999 03:00:00 GMT
 HELP!!Win 3.1 Client <==>Win NT Sql Server

Quote:

>Heeeelp!

>I'm trying to connect to a SQL Server running on a Win NT Server 4.0 from a
> Windows (for Workgroups) PC. It doesn't seem
>to work particulary well...

>I've tested the named pipe connections according to the on-line help
> documentation :

>(1) "net view " and "net use" commands work fine

>(2) When I try the "makepipe"/"readpipe" test, the following happens : The
> message string is successfully sent to
>     the SQL Server and displayed in the Dos window. At the PC end, the text
> "Data sent : 1 : Hi..." appears, but the
>    read operation fails with an error code of 58..

>So, obviously, somethings half-wrong with my named pipes setup : I manage to
> SEND data, but not to RECEIVE data from
>the Server???

>Any hints are greatly appreciated!!

Just guessing, but maybe there's a problem with the default packet size.  What
does your win.ini file say regarding db library?

----

"Experience is something you don't get until just after you need it."



Tue, 30 Nov 1999 03:00:00 GMT
 HELP!!Win 3.1 Client <==>Win NT Sql Server

Quote:

> Path:

Ireland.EU.net!EU.net!cpk-news-hub1.bbnplanet.com!news.bbnplanet.com!newsfeed.n
acamar.de!nntp.uio.no!nntp.uib.no!nntp-bergen.UNINETT.no!uninett.no!not-for-mai
l
Quote:

> Newsgroups: microsoft.public.sqlserver.connect
> Subject: HELP!!Win 3.1 Client <==>Win NT Sql Server
> Date: 12 Jun 1997 11:13:28 GMT
> Organization: UNINETT news service
> Lines: 28

> NNTP-Posting-Host: rolf.hibu.no
> X-Newsreader: News for Windows NT X1.0-62

> Heeeelp!

> I'm trying to connect to a SQL Server running on a Win NT Server 4.0 from a

Windows (for Workgroups) PC. It doesn't seem
Quote:
> to work particulary well...

> I've tested the named pipe connections according to the on-line help
documentation :

> (1) "net view " and "net use" commands work fine

> (2) When I try the "makepipe"/"readpipe" test, the following happens : The

message string is successfully sent to
Quote:
>      the SQL Server and displayed in the Dos window. At the PC end, the text

"Data sent : 1 : Hi..." appears, but the
Quote:
>     read operation fails with an error code of 58..

> So, obviously, somethings half-wrong with my named pipes setup : I manage to

SEND data, but not to RECEIVE data from
Quote:
> the Server???

> Any hints are greatly appreciated!!

> Rolf Moholth
> Buskerud College
> Faculty of Engineering
> Dept.Comp.Sci
> 3600 Kongsberg
> NORWAY

I have experienced this problem before and it is only present
with windows for workgroups. The solution is to add the following
line to the SYSTEM.INI file in the NETWORK section
DirectHost=Off

An alternative solution is to replace some of the files on the
windows for workgroups PC. These are actually available on the
NT Server 4.00 CD in a directory called D:\clients\update.wfw

All information regarding the above is available on the
Microsoft SQL Server Page on the Internet
Search for Article number Q121258 which is called "Connect to
SQL on NT 3.5 from WFW 3.11 visa Named Pipes". The article applies
to SQL Server version 4.2 but worked perfectly well on SQL Server
version 6.5

I hope this works

Niamh



Sat, 04 Dec 1999 03:00:00 GMT
 
 [ 3 post ] 

 Relevant Pages 

1. SQL Server connecting to Win 3.1 clients using tcpip

2. PowerObjects applications NT -> Win 3.1

3. [help} win 3.1 & SQL server

4. vb4-32 >>win 3.1

5. HELP - Error 50003 - VB5, Win 95, Win 98, Win NT

6. Pdox 5 and Win 3.1/locate producing win error

7. SQL with NT client will and win 3.11clients won't connect

8. transfer files from Win 3.1 to Win 98

9. VB3 program OK in WIn 3.1 but not in WIN 95

10. Creating Win 3.1 apps/network apps in win 95

11. Sql server 4.21a cannot talk to netware under win 3.1


 
Powered by phpBB® Forum Software