Connection Again and Again 
Author Message
 Connection Again and Again

I am using Dreamweaver MX to develop an ASP.Net site with an MSCE back end.

Both reside on the same machine.

For some reason the database server >SQL Server group is "DELL/VSdotNET".  I
dont know where the VSdotNET came from. The database I am interested in
connecting to is ITPSCustomers.

Using MX I create a connection string with the following:

Provider=SQLOLEDB.1;
Integrated Security=SSPI;
Persist Security Info=False;
Initial Catalog=ITPSCustomers;
Data Source=DELL\VSdotNET

When I test it within Dreamweaver MX I am informed that the connection was
made succesfully.  However when I try the page in explorer I keep getting :

System.Data.OleDb.OleDbException: Cannot open database requested in login
'ITPSCustomers'. Login fails.
at System.Data.OleDb.OleDbConnection.ProcessResults(Int32 hr)
at System.Data.OleDb.OleDbConnection.InitializeProvider()
at System.Data.OleDb.OleDbConnection.Open()
at DreamweaverCtrls.DataSet.DoInit() System.Exception: The DefaultView was
requested but no tables yet exist.
at DreamweaverCtrls.DataSet.get_DefaultView()

I have had problems trying to connect to my database now for 3 or 4 days and
this is getting beyond a joke.  Unfortunatly there are no systems people
here to help and I am pretty new to this.
Can anyone help? ......pretty please

Thanks in Advance



Sun, 29 May 2005 00:55:28 GMT
 Connection Again and Again

Hi Paul,

The error message indicates that the database 'ITPSCustomers' does not
exist on the MSDE server or the specified user account has not been granted
permissions   to this database.

Please try the following steps to check:
1. What user account do you use to log on to this machine? Is it a member
of the local admin group? Per your connection string, it appears that you
use the Windows authentication to access the SQL Server. Do you have
granted enough permission to this Windows account?

2. Use OSQL to connect to this MSDE server directly.
2.1 Open a command prompt.
2.2 Run this statement.
osql -SDELL\VSdotNET -E

Can you connect to the MSDE server? If you cannot, please try this one:
osql -SDELL\VSdotNET -Usa -P

After you can access the MSDE server via OSQL, please check whether the
database: ITPScustomers exists on this MSDE server.

3. If you can access the MSDE server via sa by using OSQL as above, please
change the connection string like this and try again:
Provider=SQLOLEDB.1;
USER ID=sa;
Password=1234;  -- (for example)
Persist Security Info=False;
Initial Catalog=ITPSCustomers;
Data Source=DELL\VSdotNET

HTH.

Sincerely,

Linda Deng
Microsoft Corporation

This posting is provided "AS IS" with no warranties, and confers no rights.



Mon, 30 May 2005 16:41:17 GMT
 
 [ 2 post ] 

 Relevant Pages 

1. Synonyms - again (Graeme hits again!)

2. multithreading again and again!

3. Licensing Again Again

4. multithreading, again and again!

5. open ADO cnt again and again

6. **** H E L P - Disk Full message (again, and again, and again).....

7. Again: Please help me with connection ID

8. Numerous sleeping processes/connections - again

9. Remote client connection with host lost over and over again

10. HELP-ME please Trusted connection again

11. after changing the sa password to '' again, I can not login again (MSDE)

12. Stored Procedure commits suicide - again and again .. why ?


 
Powered by phpBB® Forum Software