Connecting to SQL Server 6.5 with MS Access 97 via ODBC 
Author Message
 Connecting to SQL Server 6.5 with MS Access 97 via ODBC

Hello,

to describe the environment briefly, we have MS Access 97 (Service Release 2)
which accesses the MS SQL Server 6.5 (Service Pack 5). Both, Server and Client
are installed on a Windows NT Workstation 4.0 (Service Pack 6). The computer is a
Pentium II 450Mhz CPU with 96Mb RAM.

The SQL ODBC driver was tested in an old as well as the current version.

Any assignments by program code (VBA) which expect an answer of the SQL server,
such as a .OpenRecordset or similar fail.
It seems as if the SQL server wouldn't follow with sending the data.
If one passes through these calls in the de{*filter*} mode, then these usually work
straight off. One experiences the same effect, if one after a call is failed in
the code, passes through it directly in the de{*filter*} mode once more.

If one changes the environment so that one evacuates the SQL server on a Windows
NT Server, then the same application works without Problems.

Can you help me?

Thanks in advance,

Sven Worm



Sat, 15 Nov 2003 17:22:52 GMT
 Connecting to SQL Server 6.5 with MS Access 97 via ODBC

Use SQL Profiler to determine what exactly is being sent to SQL Server then paste the code into Query Analyzer and see if it works or find the problem.

Alternatively turn on ODBC trace on the client computer and look at what SQL Server is returning when the problem occurs.  This can help you pinpoint error messages from SQL Server if your program doesn't return them.

Hello,

to describe the environment briefly, we have MS Access 97 (Service Release 2)
which accesses the MS SQL Server 6.5 (Service Pack 5). Both, Server and Client
are installed on a Windows NT Workstation 4.0 (Service Pack 6). The computer is a
Pentium II 450Mhz CPU with 96Mb RAM.

The SQL ODBC driver was tested in an old as well as the current version.

Any assignments by program code (VBA) which expect an answer of the SQL server,
such as a .OpenRecordset or similar fail.
It seems as if the SQL server wouldn't follow with sending the data.
If one passes through these calls in the de{*filter*} mode, then these usually work
straight off. One experiences the same effect, if one after a call is failed in
the code, passes through it directly in the de{*filter*} mode once more.

If one changes the environment so that one evacuates the SQL server on a Windows
NT Server, then the same application works without Problems.

Can you help me?

Thanks in advance,

Sven Worm



Sun, 16 Nov 2003 04:18:01 GMT
 
 [ 2 post ] 

 Relevant Pages 

1. Connecting to MS SQL Server 6.5 via MS Access 97 and ODBC

2. ODBC timeout when connecting from ACCESS 97 to SQL Server 6.5 (heavy loaded server)

3. access 97 -> sql server 6.5 via odbc

4. MS Access 97 connect to SQL Server 6.5 Problem

5. MS ACCESS 97/SQL server 6.5: deadlock problems when accessing server tables

6. Cannot access SQL Server 6.5 SP4 databases via Access 97

7. How to migrate from MS Access 97 to MS SQL server 6.5

8. Connect OS/2 via ODBC to MS SQL Server 6.5

9. MS ACCESS 97/Sql server 6.5: deadlock problems when accesing server tables

10. MS-Access 97 to SQL Server to MS-Access 97

11. MS-Access 97 to SQL Server to MS-Access 97

12. ODBC Error Treatment after upsizing Access 97 to MS SQL 6.5


 
Powered by phpBB® Forum Software