Delete oid causing problems 
Author Message
 Delete oid causing problems

Hi all,
   I am trying to delete a record which had one of the fields as oid.
I was able to delete all the records except for 3.
I tried:
select lo_unlink(64445) from tablename
And then:
delete from tablename where id=1;

it worked
But for 3 records the delete command goes in hang.

on executing:
select lo_unlink(67787) from tablename

it gives:
lo_unlink
-----------
        -1
        -1
(2 rows)
and on deleting with the delete command it goes on hang.

I want to drop the same table but can't do that either.
I want to create another table with the same name.

Any help would be appreciated.

Thanks in advance,
Rai

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.***.com/ .

---------------------------(end of broadcast)---------------------------



Mon, 24 Nov 2003 00:43:55 GMT
 
 [ 1 post ] 

 Relevant Pages 

1. Delete oid giving problems

2. OID Install Problem, OID does not start through 9iAS

3. Large inserts/deletes/updates causing problems with rules andprocedures

4. Large inserts/deletes/updates causing problems with rules and procedures

5. BUG?: Tabular Binding DataPageSize>0 Cause Add and Delete Problems

6. Large inserts/deletes/updates causing problems with rules and

7. Partially deleted role causing problems

8. Data Mining delete cause problems?

9. Oid and Oid Vector

10. object view and oid problem

11. Problems starting the OID ldap server

12. pg_dump oid problems


 
Powered by phpBB® Forum Software