PostgreSQL + PHP 4.2x buggy with Apache? 
Author Message
 PostgreSQL + PHP 4.2x buggy with Apache?

Quote:

>It sounds like you have a problem with the persistent PostgreSQL
>connections used by PHP and Apache.  Change pg_pconnect to pg_connect and
>restart Apache to close the existing persistent connections.  My experience
>is that pg_pconnect is not as robust as pg_connect and not worth the
>increase in speed.

>George Essig

PHP is a disaster when using PostgreSQL with persistent connections.
Consider using mod_perl, Apache::Request, and Apache::DBI

    Hans

--
*{*filter*}tec Geschwinde u Schoenig*
Ludo-Hartmannplatz 1/14
A-1160 Vienna, Austria
www.postgresql.at < http://www.***.com/ >, cluster.postgresql.at
< http://www.***.com/ >, www.{*filter*}tec.at
<http://www.{*filter*}tec.at>, kernel.{*filter*}tec.at <http://kernel.{*filter*}tec.at>



Wed, 26 Jan 2005 17:20:44 GMT
 
 [ 1 post ] 

 Relevant Pages 

1. WinNT, Apache, PHP, PostgreSQL woes

2. Apache/PHP/Informix and Apache/Perl/Informix

3. [PHP] RPMs for PHP accessing PostgreSQL via ODBC over RedHat

4. PHP+MySQL vs. PHP+PostgreSQL

5. [PHP] PostgreSQL + PHP + SQL warning messages

6. Problems with Apache/Oracle/PHP

7. PHP, ASA, Apache, & missing last character

8. connecting to SQL Server 7 from Linux / Apache / PHP

9. ADMINISTRATION ORACLE VIA APACHE/PHP

10. Oracle 8i, PHP, and Apache

11. Apache + PHP + SQL 7.0

12. useability of apache, PHP, Postgres for real business apps


 
Powered by phpBB® Forum Software