7.3.1 BREAKS COMPATIBILITY with the latest PHP4 (due to libpq.so.[23]) 
Author Message
 7.3.1 BREAKS COMPATIBILITY with the latest PHP4 (due to libpq.so.[23])

The latest PHP4 (php-4.3.0) WILL NOT work with 7.3.1, since it (PHP)
expects there to be libpq.so.2, whereas 7.3.1 only provides libpq.so.3
...

... I am really astonished that I could not find anyone else who had this
problem. Am I doing something horridly wrong?

What can I do? I try ./configure'ing PHP, but it tells me:                      
gcc -o conftest -g -O2  -I/usr/pkg/include  -L/usr/pkg/lib
-R/usr/local/pgsql//lib -L/usr/local/pgsql//lib conftest.c -lpq -lcrypt
-lm  -lcrypt 1>&5
Shared object "libpq.so.2" not found                                

Complete debug.log installed.

PLEASE help...

                                                        --Jessica

      --
      Jessica L. Blank, Systems Administrator & Programmer

      www.starchefs.com
      9 East 19th St., 9th Floor  /  New York, NY 10003

      Pager (917) 675-6618

      Help Wanted. Help Found.
      www.helpwantedhelpfound.com, a division of StarChefs

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://www.***.com/



Sat, 23 Jul 2005 11:12:00 GMT
 7.3.1 BREAKS COMPATIBILITY with the latest PHP4 (due to libpq.so.[23])


Quote:
> The latest PHP4 (php-4.3.0) WILL NOT work with 7.3.1, since it (PHP)
> expects there to be libpq.so.2, whereas 7.3.1 only provides libpq.so.3
> ...

Recompile PHP, and it will work.  If you got it as an RPM, get the source=
=20
(src.rpm) RPM and issue a 'rpmbuild --rebuild php....src.rpm' (substitute t=
he=20
version and other information for the dots above...).
--=20
Lamar Owen
WGCR Internet Radio
1 Peter 4:11

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster



Sat, 23 Jul 2005 13:03:15 GMT
 
 [ 2 post ] 

 Relevant Pages 

1. 7.3.1 BREAKS COMPATIBILITY with the latest PHP4 (due to libpq.so.[23])

2. 7.3.1 BREAKS COMPATIBILITY with the latest PHP4 (due to

3. 7.3.1 BREAKS COMPATIBILITY with the latest PHP4

4. Jatco OIL(TM) C++ ObjectIdapiLibrary Free Trialware Version - oil20trl.zip (23/23)

5. pgsql/src/interfaces/libpq (fe-connect.c libpq-fe.h libpq-int.h libpqdll.def)

6. pgsql/src/interfaces/libpq libpq-fe.h libpq-int.h

7. sql 2000 install fails due to named pipes connection breaking

8. connection broken due to bad pointer

9. Compatibility of 8.0.5 clients with later releases

10. GNU C compatibility with Ingres C Preprocessor on Sun 4.1.3 or later

11. Backward compatibility with stored queries broken with Jet 4.0 and ADO2.5

12. Late Breaking News and


 
Powered by phpBB® Forum Software