Setting Filter causes error 3001 
Author Message
 Setting Filter causes error 3001

Hi all,

Problem: when I use a complex filter on my ado recordset it returns error
3001. The MSDN acknowledges this problem but does not give a solution. (
http://www.***.com/ ;en-us;Q280811 )

Is there anyone who has a workaround for this problem??

Thanx !



Mon, 14 Feb 2005 22:17:18 GMT
 Setting Filter causes error 3001

Hi,

This is limitation of ADO, not a bug and only solution in case of Filter is
to construct your filter way when it does not have groups joined by an OR
and then joined by an AND. This is same as that KB says. If you need to use
complex condition, then you always could do that against database, using
WHERE clause inside your SELECT SQL statement.

--
Val Mazur
Microsoft MVP


Quote:

> Hi all,

> Problem: when I use a complex filter on my ado recordset it returns error
> 3001. The MSDN acknowledges this problem but does not give a solution. (
> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q280811 )

> Is there anyone who has a workaround for this problem??

> Thanx !



Mon, 14 Feb 2005 23:57:45 GMT
 
 [ 2 post ] 

 Relevant Pages 

1. ADO recordset filter using wildcards - results in error 3001

2. Error 3001 when using .Filter

3. Error 3001 when setting ActiveConnection

4. Error 3001: Invalid argument

5. Create local cube, got Error# 3001

6. SQL Server 7.0 -- Error 3001

7. SQL Server 7.0 -- Error 3001

8. ADO Error 3001 Question !!

9. Error 3001 - Invalid argument

10. Help: ODBC SQLAnywhere error -3001

11. ERROR 3001 - "Invalid Argument"

12. error 3001 STUCK!


 
Powered by phpBB® Forum Software