ADO Version errors 
Author Message
 ADO Version errors

Hi,

Using Win 98 SE (writing for Win 95 - 2000 platforms)

I recently upgarded from ADO 2.5 to ADO 2.6 SP1.  I ran
ComChecker to check that ADO 2.6 SP1 was installed.  I
received the following errors:

msdatl2.dll Field 'FileVersion' mismatch:
Expect '2.52.6019.0' Got '2.50.4403.6' error

msjtes.dll Field 'FileVersion' mismatch:
Expect '4.00.4229.0' Got '4.00.2927.8' error

msadco.dll Unknown Class ID = {9381d8f1-0288-11d0-9501-
00aa00b911a5} warning

I'm unable to find any info on these errors in the
ComChecker help file or how to correct them.  I assume the
earlier 2.5 version dlls are causing the mismatch.  Got a
project ready to deliever but now am concerned.  Any ideas?



Sun, 27 Jun 2004 03:07:21 GMT
 ADO Version errors

Looks to me like you have a failed 2.6 upgrade; however, this won't affect
your application deployment on other machines.

This is due to the fact that you will be deploying the mdac_typ.exe file to
deploy all the data access components, not the files individually. Your
file mismatch problems will not be propagated to the machines you install
your application on.

In your case, I would highly recommend reapplying the MDAC 2.6 sp1 update.
If this doesn't resolve the errors as displayed by Component Checker, then
you should roll back the 2.6 sp1 installation using the following command:

c:\program files\common files\microsoft shared\dasetup\dasetup /u

You should then rerun Component Checker to ensure you've arrived at a
stable state.

Steven Bras, MCSD
Microsoft Developer Support/Visual Basic WebData

This posting is provided "AS IS" with no warranties, and confers no rights.

Are you secure? For information about the Microsoft Strategic Technology
Protection Program and to order your FREE Security Tool Kit, please visit
http://www.microsoft.com/security.



Wed, 30 Jun 2004 06:52:27 GMT
 
 [ 2 post ] 

 Relevant Pages 

1. mdac version, ado version

2. ADO 2.6 SP1 File Version Errors

3. MDAC version VS ADO version

4. ADO Error - Is it a version conflict?

5. Visual C++ 5.0 #import Causes Errors with ADO Version 2.0

6. Version difference from ADO 2.5 to ADO 2.7

7. What version of ADO is ADO.NET ?

8. ODBC-SDK, DAO, ADO ? // ADO: doc, version

9. Upgrading to ADO from RDO and ADO Version Conflicts

10. Error on Upgrade of version 6.5 to version 7

11. Master, msdb and model (old version and new version) i need old version

12. The Error 3041 (version error)


 
Powered by phpBB® Forum Software