HTML-CLIENT problems. 
Author Message
 HTML-CLIENT problems.

Hello everybody.

I have a problem with Dynamic 4GL. I have tried every thing in the configuration, and nothing makes it work. My configuration is:

-               MS WINNT SP5. IIS 3.0

-       Four j's Universal Runner Version 3.00.2i
        Built Feb 22 2000 16:05:34
        (c) 1989-1998 Four J's Development Tools

-       Four j's Universal HTML client - server (fglhtmld).
        Version 1.01.5a3
        Built Dec  3 1998 10:58:04

-       Four j's Universal Runner Version 3.00.2i
        Built Feb 22 2000 16:05:34
               (c) 1989-1998 Four J's Development Tools

-       fglcl: HTML Client, Communication process
        Version 1.01.5a3
        Build Dec  3 1998 10:57:54
        Copyright (C) 1989-1998 Four J's Development Tools

When I use the html server, with the command:
fglhtmld -f menu.conf -d
and using debug=99, I get a log file, inside what I see this error ("Nothing in or error on pipe"):
....
....
[DBG-03].****  Summary of process creation
[DBG-03].****  ---------------------------
[DBG-04].***   Pipe to Task ......... 100
[DBG-04].***   Pipe from Task ....... 132
[DBG-04].***   Process ID ........... 335
[LOG-06].Task (fglrun) created with parameters : host='192.168.0.1', pid='335', program='fglrun.exe menu.42r'
[DBG-30].***** <- Task::init() - ok
[DBG-30].***** -> Task::TaskReadThread()
[DBG-50].***** <- clRead()
[DBG-30].***** -> Task::taskRead()
[DBG-02].***** -> lSocket::~lSocket ()
[DBG-02].****  We now have 2 socket(s) working.
[DBG-02].****  Socket was not closed before calling ~lSocket().
[DBG-02].***** <- lSocket::~lSocket ()
[DBG-60].****  select()
[DBG-31].***   Nothing in or Error on Pipe...
[DBG-30].***** <- Task::taskRead()
[DBG-30].***** -> Task::~Task()
[DBG-31].****  Pipe from task is being cleared...
[DBG-31].****  Pipe to task is being cleared...
[DBG-31].****  Process is being cleared...
[DBG-31].****  Task was already ended.
[LOG-06].Task (fglrun) #335 deleted with parameters : erg='0', waitpid='0'
...
...

So, in my browser I cannot see any piece of 4GL-code.

Why is this happening?

Thanks in advance.



Wed, 18 Jun 1902 08:00:00 GMT
 HTML-CLIENT problems.


  "=?ISO-8859-1?Q?Juan=20Manuel=20Hern=E1ndez=20del=20Olmo?="
Quote:

> Hello everybody.

> I have a problem with Dynamic 4GL. I have tried every thing in the

configuration, and nothing makes it work. My configuration is:
Quote:

> -               MS WINNT SP5. IIS 3.0

> -  Four j's Universal Runner Version 3.00.2i
>    Built Feb 22 2000 16:05:34
>    (c) 1989-1998 Four J's Development Tools

> -  Four j's Universal HTML client - server (fglhtmld).
>    Version 1.01.5a3
>    Built Dec  3 1998 10:58:04

> -  Four j's Universal Runner Version 3.00.2i
>    Built Feb 22 2000 16:05:34
>                (c) 1989-1998 Four J's Development Tools

> -  fglcl: HTML Client, Communication process
>    Version 1.01.5a3
>    Build Dec  3 1998 10:57:54
>    Copyright (C) 1989-1998 Four J's Development Tools

> When I use the html server, with the command:
> fglhtmld -f menu.conf -d
> and using debug=99, I get a log file, inside what I see this error

("Nothing in or error on pipe"):
Quote:
> ....
> ....
> [DBG-03].****  Summary of process creation
> [DBG-03].****  ---------------------------
> [DBG-04].***   Pipe to Task ......... 100
> [DBG-04].***   Pipe from Task ....... 132
> [DBG-04].***   Process ID ........... 335
> [LOG-06].Task (fglrun) created with parameters : host='192.168.0.1',

pid='335', program='fglrun.exe menu.42r'

- Show quoted text -

Quote:
> [DBG-30].***** <- Task::init() - ok
> [DBG-30].***** -> Task::TaskReadThread()
> [DBG-50].***** <- clRead()
> [DBG-30].***** -> Task::taskRead()
> [DBG-02].***** -> lSocket::~lSocket ()
> [DBG-02].****  We now have 2 socket(s) working.
> [DBG-02].****  Socket was not closed before calling ~lSocket().
> [DBG-02].***** <- lSocket::~lSocket ()
> [DBG-60].****  select()
> [DBG-31].***   Nothing in or Error on Pipe...
> [DBG-30].***** <- Task::taskRead()
> [DBG-30].***** -> Task::~Task()
> [DBG-31].****  Pipe from task is being cleared...
> [DBG-31].****  Pipe to task is being cleared...
> [DBG-31].****  Process is being cleared...
> [DBG-31].****  Task was already ended.
> [LOG-06].Task (fglrun) #335 deleted with parameters : erg='0',
waitpid='0'
> ...
> ...

> So, in my browser I cannot see any piece of 4GL-code.

> Why is this happening?

> Thanks in advance.

Please verify following checklists, i did it on unix server,

1.Installation of html components from D4GL cd on webserver.
2.Installation of html components on application server, where 4gl
resides, fglhtmld will be running on this server.

3.Configuration of fglcl.conf file in cgi-bin directory, follow syntax
given in the file, where you will mention server ip address and unique
servernum,

4.Configuration of appication.conf file in application server, you
should give same server num here as well.

5.Configure start script in application server, this script will invoke
4gl application, you should have all d4gl environment variables and
command to start application. In the script use CD to point correct
directory.

6.Start fglhtmld from application home directory.

7.Make sure emulate HTML in application conf is set to "1", read manual
for details.

8.FGLGUI should be set to "2" in start script, which is html interface.

Regards
Anas

Sent via Deja.com http://www.deja.com/
Before you buy.



Wed, 18 Jun 1902 08:00:00 GMT
 HTML-CLIENT problems.

Hello

Use the Four J's List .
http://www1.4js.com/html/supp/mailing.htm
they are a lot of news on Four J's Product (Dynamic 4gl)
I hope , you can find your answer

Pierre Delandre

Quote:
-----Original Message-----

Sent: Thursday, June 15, 2000 2:03 AM

Subject: HTML-CLIENT problems.

Hello everybody.

I have a problem with Dynamic 4GL. I have tried every thing in the
configuration, and nothing makes it work. My configuration is:

-               MS WINNT SP5. IIS 3.0

-       Four j's Universal Runner Version 3.00.2i
        Built Feb 22 2000 16:05:34
        (c) 1989-1998 Four J's Development Tools

-       Four j's Universal HTML client - server (fglhtmld).
        Version 1.01.5a3
        Built Dec  3 1998 10:58:04

-       Four j's Universal Runner Version 3.00.2i
        Built Feb 22 2000 16:05:34
               (c) 1989-1998 Four J's Development Tools

-       fglcl: HTML Client, Communication process
        Version 1.01.5a3
        Build Dec  3 1998 10:57:54
        Copyright (C) 1989-1998 Four J's Development Tools

When I use the html server, with the command:
fglhtmld -f menu.conf -d
and using debug=99, I get a log file, inside what I see this error ("Nothing
in or error on pipe"):
....
....
[DBG-03].****  Summary of process creation
[DBG-03].****  ---------------------------
[DBG-04].***   Pipe to Task ......... 100
[DBG-04].***   Pipe from Task ....... 132
[DBG-04].***   Process ID ........... 335
[LOG-06].Task (fglrun) created with parameters : host='192.168.0.1',
pid='335', program='fglrun.exe menu.42r'
[DBG-30].***** <- Task::init() - ok
[DBG-30].***** -> Task::TaskReadThread()
[DBG-50].***** <- clRead()
[DBG-30].***** -> Task::taskRead()
[DBG-02].***** -> lSocket::~lSocket ()
[DBG-02].****  We now have 2 socket(s) working.
[DBG-02].****  Socket was not closed before calling ~lSocket().
[DBG-02].***** <- lSocket::~lSocket ()
[DBG-60].****  select()
[DBG-31].***   Nothing in or Error on Pipe...
[DBG-30].***** <- Task::taskRead()
[DBG-30].***** -> Task::~Task()
[DBG-31].****  Pipe from task is being cleared...
[DBG-31].****  Pipe to task is being cleared...
[DBG-31].****  Process is being cleared...
[DBG-31].****  Task was already ended.
[LOG-06].Task (fglrun) #335 deleted with parameters : erg='0', waitpid='0'
...
...

So, in my browser I cannot see any piece of 4GL-code.

Why is this happening?

Thanks in advance.



Wed, 18 Jun 1902 08:00:00 GMT
 
 [ 3 post ] 

 Relevant Pages 

1. How to construct html table to display ado data in an html enabled e-mail client

2. [WEBMASTER] 'www/html/users-lounge commercial-support.html events.html index.html limitations.html subunsub.html'

3. [WEBMASTER] 'www/html helpus.html home.html logo.html sites.html sponsors.html'

4. [WEBMASTER] 'www/html index.html mirrors.html news.html sites.html'

5. [WEBMASTER] 'www/html index.html mirrors.html news.html sites.html'

6. DrillThrough support in html client

7. Viewing OLAP cube data in HTML without client-side ActiveX

8. CO-Golden-266802--Client/Server-RDBMS-SQLSERVER-ORACLE-SYBASE-Informix-HTML-Java

9. MD-Rockville-265713--Client/Server-HTML-Java-ORACLE-Developer 2000-ORACLE Forms-

10. NJ-Florham Park-93529--Client/Server-HTML-MS Office-Networking-PC-Visual Basic-W

11. NJ-Florham Park-93529--Client/Server-HTML-MS Office-Networking-PC-Visual Basic-W


 
Powered by phpBB® Forum Software