Compilation problem 
Author Message
 Compilation problem

I think this may be more of a Unix problem than an Informix problem, but
hopefully somebody will of had the same problem & can help me out.

When I run :-

 "c4gl -o round_cent.4ge stub.o round_cent.o"

 I get the following error:-

Undefined                       first referenced
 symbol                             in file
getspnam
/usr/informix/lib/tools/libos.a(ospasswd.o)
round_cent.4ge: fatal error: Symbol referencing errors. No output written to
round_cent.4ge

I have copied these files onto a different SCO 5.05 box, running the same
versions of Informix/SCO, & it runs fine there.

Any ideas would be great,

Thanks in advance,

John.



Wed, 18 Jun 1902 08:00:00 GMT
 Compilation problem

Quote:

> I think this may be more of a Unix problem than an Informix problem,

It is...

Quote:
> but hopefully somebody will of had the same problem & can help me out.
> When I run :-

>  "c4gl -o round_cent.4ge stub.o round_cent.o"

>  I get the following error:-

> Undefined                       first referenced
>  symbol                             in file
> getspnam
> /usr/informix/lib/tools/libos.a(ospasswd.o)
> round_cent.4ge: fatal error: Symbol referencing errors. No output written to
> round_cent.4ge

> I have copied these files onto a different SCO 5.05 box, running the same
> versions of Informix/SCO, & it runs fine there.

Your other box must have the missing library -- or a different version
of the same library.  Basically, on the other machine, the system
libraries provide the getspnam() (get shadow password file entry based
on user name) function, and on your local machine, they do not.
Something was installed differently on the two; I suggest installing the
extra package on the machine with the problems.

You could try using nm on the various system libraries to find out which
one provides getspnam().  Then arrange to install that library on the
other machine.  But be careful; other libraries may also be affected.

--
Yours,

Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN
     "I don't suffer from insanity; I enjoy every minute of it!"



Wed, 18 Jun 1902 08:00:00 GMT
 
 [ 2 post ] 

 Relevant Pages 

1. compilation problem in sql server7.0

2. ASP Compilation Problems?

3. VACUUM LAZY compilation problem

4. AIX compilation problems (was Re: Proposal ...)

5. AIX compilation problems (was Re: Proposal ...)

6. Compilation problem after installing DAO 3.6

7. compilation problem

8. ESQL/C compilation problem

9. OCCI/OCI and aCC compilation problems under HP-UX

10. Trigger Compilation Problem

11. Trigger compilation problem

12. Pro*Fortran compilation problem on Sun Solaris 2.5.1, RDBMS 7.3.3


 
Powered by phpBB® Forum Software