Informix / PHP / Apache 
Author Message
 Informix / PHP / Apache
I recently installed PHP for Apache.

I am running Solaris 2.6, Informix 7.31, and the latest version of Apache
and PHP.

The connection between Apache / PHP and Informix works great.  However,
after about a week of moderate use, the PHP scripts can no longer attach to
the Informix server.  If I restart Apache, everything works fine again for
about a week.

Any suggestions?

--
Jay Aymond
Community Coffee Company
Baton Rouge, LA
www.communitycoffee.com



Mon, 07 Jun 2004 06:01:25 GMT
 Informix / PHP / Apache

Are you using ifx_connect or ifx_pconnect?

I used ifx_pconnect but when for any reasing a have to restart the engine
the 'persistent connection' in the Apache thread was no longer valid so I
also needed to restart Apache.

As the Apache and the IDS are in diferent boxes and could get sync, I
changed all my code for ifx_connect.

Hope it helps

Quote:
----- Original Message -----


Sent: Wednesday, December 19, 2001 4:01 PM
Subject: Informix / PHP / Apache

| I recently installed PHP for Apache.
|
| I am running Solaris 2.6, Informix 7.31, and the latest version of Apache
| and PHP.
|
| The connection between Apache / PHP and Informix works great.  However,
| after about a week of moderate use, the PHP scripts can no longer attach
to
| the Informix server.  If I restart Apache, everything works fine again for
| about a week.
|
| Any suggestions?
|
| --
| Jay Aymond
| Community Coffee Company
| Baton Rouge, LA
| www.communitycoffee.com
|
|



Mon, 07 Jun 2004 22:19:48 GMT
 Informix / PHP / Apache
I think I figured this out ... it seems that if I use TCP connections the
problem disappears.  Only the shared memory connections cause problems.


Quote:
> I recently installed PHP for Apache.

> I am running Solaris 2.6, Informix 7.31, and the latest version of Apache
> and PHP.

> The connection between Apache / PHP and Informix works great.  However,
> after about a week of moderate use, the PHP scripts can no longer attach
to
> the Informix server.  If I restart Apache, everything works fine again for
> about a week.

> Any suggestions?

> --
> Jay Aymond
> Community Coffee Company
> Baton Rouge, LA
> www.communitycoffee.com



Wed, 16 Jun 2004 23:37:05 GMT
 
 [ 3 post ] 

 Relevant Pages 

1. Apache/PHP/Informix and Apache/Perl/Informix

2. Informix+web datablate+php+apache

3. Instalacion de php como modulo apache con soporte para Informix SCO

4. PHP/Apache/Informix questions...

5. suse+apache+informix+php

6. Cannot 'make' Apache / PHP / Informix IIF200

7. php+apache+informix

8. php+informix+apache

9. Problems with Informix, Apache and PHP Installation

10. PHP/MySQL vs PHP/Informix performance

11. connecting to SQL Server 7 from Linux / Apache / PHP

12. access via linux-apache-php


 
Powered by phpBB® Forum Software