Apache/PHP/Informix and Apache/Perl/Informix 
Author Message
 Apache/PHP/Informix and Apache/Perl/Informix

For instaling DBD:DBI:Informix try typing as root

# perl -MCPAN -e 'install DBD::Informix'

you need to have Internet access from the server.

To add ifx_* functions to PHP without afecting to much the current apache
server (about 2 minutes down time).

1 Download source tarball in a temp directory (apache/php)
2 You already have CSDK configured and running
3 Configure Apache/PHP with the apropiate options
4 Make but don't install both programs
5 Stop current server (apachectl stop)
6a Backup current binaries (httpd, libphp4.a).
6b Copy the new libraries/programs to the current directories.
  (httpd, libphp4.a)
7 Start the new server (apachectl start)

Quote:
----- Original Message -----


Sent: Tuesday, January 29, 2002 7:27 PM
Subject: RE: Older Informix versions on RH 7.2

| | It works !
| | Many, many thanks for your valuable assistance, I had wasted
| | hours and hours trying to get the 4gl compiler to work.
| |
| | ..Now I just need to get a web interface to SE working in the
| | same environment to complement the 4gl's for extranet access.
| |
| | Which is best/easiest to get working ; PHP or Perl ?
| | Do you have either of these working in the same environment ?
| |
|
| BTW: have noticed the i4gl spash screen is slightly mis-aligned, although
| seems to compile 4gl's ok. Could this be termcap problem ? Does it need
| different one to SQL which works ok, or maybe something to do with runtime
?
|
|
| >I have running linux/apache/php/csdk to Informix (for extranet access)
| >and linux/php/dbi/dbd/informix just for fun.
|
| >Both are easy to get working, wich one is better for you to get
| programming?
|
| I am happy programming with both and having both would be best solution as
| each offers specific benefits in this context, so would like both PHP and
| Perl.
|
|
| | RH7.2 installs Perl and PHP from std but it appears neither
| | will recognise any commands to access the Informix DB.
| | I understand that a re-compile of these may be necessary to
| | include flags or modules for Informix, but cannot even locate
| | the base installs to check or confirm the configuration options.
| | Any help would be most appreciated.
| |
|
| >Check CDI archives are many threads for configuring apache/php.
|
| >Was easier for to remove the std RPM (apache-*, php-*) included with RH,
| >download the source tarball, do the ./configure and make with the flags
to
| >include the informix libraries.
|
| I was afraid of that, not wanting to risk breaking the installed
Apache/PHP
| and Perl which are already running Intranet apps ok. I think best will
clone
| the HD and then give it a try. Do I need to remove all Apache,PHP and Perl
?
| Does it matter which order they are removed/re-installed (PHP/Perl)?
| Is it ok to re-install all latest versions in RH7.2 or will need to find
| same
| to avoid any compat issues ?
|
|



Sun, 18 Jul 2004 22:27:43 GMT
 Apache/PHP/Informix and Apache/Perl/Informix

If you've activated dso on Apache all you need to do is add
the LoadModule in the appropriate place eg virtual host etc,
then restart apache and it works.  The only apache file that is
altered in httpd.conf

Quote:

> For instaling DBD:DBI:Informix try typing as root

> # perl -MCPAN -e 'install DBD::Informix'

> you need to have Internet access from the server.

> To add ifx_* functions to PHP without afecting to much the current apache
> server (about 2 minutes down time).

> 1 Download source tarball in a temp directory (apache/php)
> 2 You already have CSDK configured and running
> 3 Configure Apache/PHP with the apropiate options
> 4 Make but don't install both programs
> 5 Stop current server (apachectl stop)
> 6a Backup current binaries (httpd, libphp4.a).
> 6b Copy the new libraries/programs to the current directories.
>   (httpd, libphp4.a)
> 7 Start the new server (apachectl start)

> ----- Original Message -----


> Sent: Tuesday, January 29, 2002 7:27 PM
> Subject: RE: Older Informix versions on RH 7.2

> | | It works !
> | | Many, many thanks for your valuable assistance, I had wasted
> | | hours and hours trying to get the 4gl compiler to work.
> | |
> | | ..Now I just need to get a web interface to SE working in the
> | | same environment to complement the 4gl's for extranet access.
> | |
> | | Which is best/easiest to get working ; PHP or Perl ?
> | | Do you have either of these working in the same environment ?
> | |
> |
> | BTW: have noticed the i4gl spash screen is slightly mis-aligned, although
> | seems to compile 4gl's ok. Could this be termcap problem ? Does it need
> | different one to SQL which works ok, or maybe something to do with runtime
> ?
> |
> |
> | >I have running linux/apache/php/csdk to Informix (for extranet access)
> | >and linux/php/dbi/dbd/informix just for fun.
> |
> | >Both are easy to get working, wich one is better for you to get
> | programming?
> |
> | I am happy programming with both and having both would be best solution as
> | each offers specific benefits in this context, so would like both PHP and
> | Perl.
> |
> |
> | | RH7.2 installs Perl and PHP from std but it appears neither
> | | will recognise any commands to access the Informix DB.
> | | I understand that a re-compile of these may be necessary to
> | | include flags or modules for Informix, but cannot even locate
> | | the base installs to check or confirm the configuration options.
> | | Any help would be most appreciated.
> | |
> |
> | >Check CDI archives are many threads for configuring apache/php.
> |
> | >Was easier for to remove the std RPM (apache-*, php-*) included with RH,
> | >download the source tarball, do the ./configure and make with the flags
> to
> | >include the informix libraries.
> |
> | I was afraid of that, not wanting to risk breaking the installed
> Apache/PHP
> | and Perl which are already running Intranet apps ok. I think best will
> clone
> | the HD and then give it a try. Do I need to remove all Apache,PHP and Perl
> ?
> | Does it matter which order they are removed/re-installed (PHP/Perl)?
> | Is it ok to re-install all latest versions in RH7.2 or will need to find
> | same
> | to avoid any compat issues ?
> |
> |

--
Paul Watson             #          
Oninit Ltd              # Growing old is mandatory
Tel: +44 1436 672201    # Growing up is optional
Fax: +44 1436 678693    #
www.oninit.com          #


Sun, 18 Jul 2004 23:39:24 GMT
 
 [ 2 post ] 

 Relevant Pages 

1. Informix+web datablate+php+apache

2. Instalacion de php como modulo apache con soporte para Informix SCO

3. Informix / PHP / Apache

4. PHP/Apache/Informix questions...

5. suse+apache+informix+php

6. Cannot 'make' Apache / PHP / Informix IIF200

7. php+apache+informix

8. php+informix+apache

9. Problems with Informix, Apache and PHP Installation

10. EJB sample to Apache WebServer + Apache Tomcat Server + JBoss Ser

11. Paradox Apache and Apache-ssl Proxy document now available


 
Powered by phpBB® Forum Software