BUG : Paradox Bug? 
Author Message
 BUG : Paradox Bug?

I'm scratching my head over what Paradox thinks is a corrupt table, I can
see no reason why it is corrupt and I can still view all the data in the
table, this leads me to think "bug!"

The circumstances are these....

The table has 10 fields 4 of which make up the primary key. When the table
gets more than 220,000 records or so, the index seem to become corrupt and
searching through the table becomes way too slow, presumably because the
index are bad.

If I remove the 4 primary keys, the table verifies OK, and adding a new
field as the primary key and setting the other 4 fields as a secondary
index will not cause the corruption. However, one of our legacy
applications requires those 4 fields to be the primary key! So this is not
the soloution.

The error reported by Paradox Table Repair is BTREE Record mismatch in
block(1) to Block(2) (88). Error code 53, level 2.

Any Ideas?

Stu.

--

 ---  ---


 |   |###
 |   |###     http://www.***.com/
 |   |###
 |___|###    The futures bright, it's blue and white...



Sat, 04 Sep 1999 03:00:00 GMT
 BUG : Paradox Bug?

You might try changing the block size of the table.



Mon, 06 Sep 1999 03:00:00 GMT
 BUG : Paradox Bug?

Quote:

> The error reported by Paradox Table Repair is BTREE Record mismatch in
> block(1) to Block(2) (88). Error code 53, level 2.

> Any Ideas?

> Stu.

Did you try to update the BDE? I had lots of problems with corrupt data,
but after installing BDE 3.5 from www.borland.com Paradox runs
fine.

Joern



Tue, 07 Sep 1999 03:00:00 GMT
 
 [ 3 post ] 

 Relevant Pages 

1. BUGS idapi BUGS idapi BUGS idapi BUGS

2. Bugs, Bugs, Bugs ...

3. BUG BUG BUG: VB5+DAO 3.51

4. BUGS BUGS BUGS (Disappointed with Borland!)

5. WAS BUG, BUG, BUG

6. help, help ???? bug, bug

7. SQL Server Bug or Query Bug?

8. Bug or not bug? - Survey

9. Need patch for bug fix for bug#56085 ref:Q244548

10. Bug: BUG #: 18017 (6.5) Article Q187370 - Help

11. MSXML 3.0 encoding bug or bug in SQL2k XML support

12. Bug or not to Bug ?!


 
Powered by phpBB® Forum Software