IDAPI uninitialized problem? 
Author Message
 IDAPI uninitialized problem?

I am using the Paradox Runtime on Network.  Currently, some of the
runtime users in the network(not all of them) are having the error
message "IDAPI is not initialized" on the screen.  I search all the
drives, but I can't find any .lck file.  Then, I also compare the IDAPI
configuration Utility between a good and a problem users ID.  Seems that
they are no difference.  

If you know how to solve the problem, please let me know.

Thanks.
==THOMAS==



Tue, 07 Jul 1998 03:00:00 GMT
 IDAPI uninitialized problem?

: I am using the Paradox Runtime on Network.  Currently, some of the
: runtime users in the network(not all of them) are having the error
: message "IDAPI is not initialized" on the screen.  I search all the
: drives, but I can't find any .lck file.  Then, I also compare the IDAPI
: configuration Utility between a good and a problem users ID.  Seems that
: they are no difference.  

: If you know how to solve the problem, please let me know.

assuming you're using windows, but some of these hints might
be applicable to more platforms:

Try copying the IDAPI.CFG file from the good location to a
problem location (backup first)
Check the win.ini file, to see if the [IDAPI] sections are
the same
See if IDAPI*.DLL is on the search path on all locations
Check the versions of the config util
(date/time/size/versioninfo) and the idapi*.dll
see if not only idapi*.dll is there, but even the other id*.dll
files, (or the same files on both locations)
check readability/writability for users/locations on the
network (also the netdir)

Well, can't think of anything else now...

Jelle Paul

--
+-------------------------------------------------------+

| Vrije Universiteit Amsterdam    |                     |
+-------------------------------------------------------+



Fri, 10 Jul 1998 03:00:00 GMT
 IDAPI uninitialized problem?

: I am using the Paradox Runtime on Network.  Currently, some of the
: runtime users in the network(not all of them) are having the error
: message "IDAPI is not initialized" on the screen.  I search all the
: drives, but I can't find any .lck file.  Then, I also compare the IDAPI
: configuration Utility between a good and a problem users ID.  Seems that
: they are no difference.  

Check their C:\TEMP (or similar) directory...

--
=========================================================================
Kasey K. S. Chang (a guy)             | Paradox for Windows Programmer

URL> http://userwww.sfsu.edu/~kschang | X-COM Guru   General PC expert
--------------------------------------+----------------------------------
Editor of XCOM and XCOM2 UN-official Strategy Guide -- FREE!  (See URL)



Sat, 11 Jul 1998 03:00:00 GMT
 IDAPI uninitialized problem?
Hello Alten,

Quote:

> : I am using the Paradox Runtime on Network.  Currently, some of the
> : runtime users in the network(not all of them) are having the error
> : message "IDAPI is not initialized" on the screen.  I search all the

> assuming you're using windows, but some of these hints might
> be applicable to more platforms:

> Try copying the IDAPI.CFG file from the good location to a
> problem location (backup first)

I have User with Runtime on WfW PC's with active Network, but only local  
databases. The Runtime IDAPI of these PC's needs a Netdir Entry ( I used  
C: ) an then it starts up, without them ...nothing goes on!

A normal Pdox 5 Win starts on a PC with network and no Entry for Netdir...
I think different IDAPI's.
ReadYa Micha.



Sun, 12 Jul 1998 03:00:00 GMT
 
 [ 4 post ] 

 Relevant Pages 

1. BUGS idapi BUGS idapi BUGS idapi BUGS

2. Same ole problem: Reference of uninitialized composite

3. Reference Uninitialized composite problem again

4. idapi bcb5 versus idapi bc5.01

5. DELPHI IDAPI => PARADOX 5 IDAPI

6. Problems with Ingres and BDE configuration - idapi.cfg (1/1)

7. Problems with Ingres and BDE configuration - idapi.cfg (0/1)

8. DELPHI + PARADOX 5.0 IDAPI PROBLEM

9. Report Smith / IDAPI problem

10. Delphi3/Access95/IDAPI Problem

11. Problems with IDAPI


 
Powered by phpBB® Forum Software