DB2 PDE 7.1 on RedHat 7.1 problem 
Author Message
 DB2 PDE 7.1 on RedHat 7.1 problem

Thanks in advance for your time.  I have already ready through the
GREAT how-to by Dan (yup the currently updated version which includes
support for RH 7.1.) and have inplemented all the fixs/setups/settings
he suggested.  This problem existed when I ran RH 7.0 but I got it
fixed when I switched to Java 1.1.8.  Because this is no longer an
option I have to find a way to make Java2 work.

Here is my problem:
When I try to run db2cc I get the splash screen and then.... splash
screen.... ok still there.... etc... etc.. etc...

Just to make sure, I have let the splash screen run for hours but
control center does not come up.  I took a look at db2cc and
discovered that there is one of two libraries that I just don't seem
to have.  If "$JAVA_HOME" is defined I am missing classes.zip (I have
checked every file in my system for it.)  Even if "$JAVA_HOME" is not
defined I am missing db2plug.zip.

If I kill -9 the process (because control-c does not do it) I get this
message:


I would just switch back to RH 7 but it is not my decision.  Thanks
again for any help.  Let me know If there is any more infor I can give
you.



Sun, 16 Nov 2003 06:38:52 GMT
 DB2 PDE 7.1 on RedHat 7.1 problem

Oh ahhh ya my question is:

   A) Are these files the reason why I cannot get db2cc working?

and if so

   B) Where can I get these files?

and then

   C) Why did they not get installed originally?

Quote:

> Thanks in advance for your time.  I have already ready through the
> GREAT how-to by Dan (yup the currently updated version which includes
> support for RH 7.1.) and have inplemented all the fixs/setups/settings
> he suggested.  This problem existed when I ran RH 7.0 but I got it
> fixed when I switched to Java 1.1.8.  Because this is no longer an
> option I have to find a way to make Java2 work.

> Here is my problem:
> When I try to run db2cc I get the splash screen and then.... splash
> screen.... ok still there.... etc... etc.. etc...

> Just to make sure, I have let the splash screen run for hours but
> control center does not come up.  I took a look at db2cc and
> discovered that there is one of two libraries that I just don't seem
> to have.  If "$JAVA_HOME" is defined I am missing classes.zip (I have
> checked every file in my system for it.)  Even if "$JAVA_HOME" is not
> defined I am missing db2plug.zip.

> If I kill -9 the process (because control-c does not do it) I get this
> message:

> ./db2cc line 57: 12801 killed   jre $JRE_OPTIONS -cp $JRE_CLASSPATH CC

> I would just switch back to RH 7 but it is not my decision.  Thanks
> again for any help.  Let me know If there is any more infor I can give
> you.



Sun, 16 Nov 2003 22:05:44 GMT
 DB2 PDE 7.1 on RedHat 7.1 problem
Bob:

I'm sure it's not the recommended approach but what I did was modify the
db2cc script to start my Java environment rather than modify my environment
to find db2.  If you have a functioning Java environment, comment out the
last line or two of the script (i.e. jre) and and tell it to start java.  
Also, don't let it obliterate your syste CLASSPATH variable at the top of
the script as it is wont to do.

Chuck Davis

P.S.  Incidentally, it works fine with jdk1.3

Quote:

> Oh ahhh ya my question is:

>    A) Are these files the reason why I cannot get db2cc working?



Sun, 16 Nov 2003 22:45:21 GMT
 DB2 PDE 7.1 on RedHat 7.1 problem

Quote:
>Oh ahhh ya my question is:

>   A) Are these files the reason why I cannot get db2cc working?

Which files?
Quote:
>and if so

>   B) Where can I get these files?

>and then

>   C) Why did they not get installed originally?


>> Thanks in advance for your time.  I have already ready through the
>> GREAT how-to by Dan (yup the currently updated version which includes
>> support for RH 7.1.) and have inplemented all the fixs/setups/settings
>> he suggested.  This problem existed when I ran RH 7.0 but I got it
>> fixed when I switched to Java 1.1.8.  Because this is no longer an
>> option I have to find a way to make Java2 work.

>> Here is my problem:
>> When I try to run db2cc I get the splash screen and then.... splash
>> screen.... ok still there.... etc... etc.. etc...

>> Just to make sure, I have let the splash screen run for hours but
>> control center does not come up.  I took a look at db2cc and
>> discovered that there is one of two libraries that I just don't seem
>> to have.  If "$JAVA_HOME" is defined I am missing classes.zip (I have
>> checked every file in my system for it.)  Even if "$JAVA_HOME" is not
>> defined I am missing db2plug.zip.

>> If I kill -9 the process (because control-c does not do it) I get this
>> message:

>> ./db2cc line 57: 12801 killed   jre $JRE_OPTIONS -cp $JRE_CLASSPATH CC

>> I would just switch back to RH 7 but it is not my decision.  Thanks
>> again for any help.  Let me know If there is any more infor I can give
>> you.



Mon, 17 Nov 2003 09:09:53 GMT
 DB2 PDE 7.1 on RedHat 7.1 problem
classes.zip and db2plug.zip are the files I am missing.


Mon, 17 Nov 2003 21:24:57 GMT
 DB2 PDE 7.1 on RedHat 7.1 problem

Quote:
>classes.zip and db2plug.zip are the files I am missing.

classes.zip is part of your Java distribution, and I don't seem to have
db2plug.zip anywhere and can bring up the CC successfully on my Linux box
(RH6.2).  Heck, I'm on my OS/2 box running an X server and saw the CC come
across the network.

I don't think that db2plug.zip has anything to do with your problem, although
if your JRE doesn't have classes.zip, that certainly would be a problem.

I am using JDK 1.1.8 from IBM on my Linux box.



Tue, 18 Nov 2003 22:01:41 GMT
 
 [ 6 post ] 

 Relevant Pages 

1. DB2 7.1 PDE or DB2 7.1 EE

2. DB2 7.1 PDE and MSQuery problems

3. General question on DB2 7.1 PDE

4. Problems with Command Center on DB2 v7.1 Fixpak 3 on Redhat Linux 7.1

5. DB2 7.1 on RedHat 7.0 and IBMJDK2-13 Install

6. PDE 7.1 for Windows - Can't start admin server

7. Command Center Error in UDB PDE for win 7.1 FP 2a

8. 7.1 PDE for Linux - time limited?

9. Unable to drop table in 7.1 PDE

10. sigsegv 11* for db2cc in linux 7.1 pde

11. Problem with oracle 8.1.5 on RedHat 7.1

12. setup problems in RedHat 7.1


 
Powered by phpBB® Forum Software