SQLParamData after SQLPutData returns SQL0423N 
Author Message
 SQLParamData after SQLPutData returns SQL0423N

I'm trying to update a CLOB column in a C program using CLI. Here's a
snippet of relevant code:

...
len = SQL_DATA_AT_EXEC;

<bindlen is length of data I wish to insert>

retcode = SQLBindParameter(hStmt,
                (SQLUSMALLINT) ipos,
                SQL_PARAM_INPUT,
                SQL_C_CLOB_LOCATOR,
                SQL_CLOB_LOCATOR,
                (SQLUINTEGER)bindlen,
                0,
                clobloc,
                (SQLUINTEGER)bindlen,
                len);
...
retcode = SQLExecute(hStmt);
...
retcode = SQLParamData(hStmt, &ValuePtr);
...
<buflen = length of buffer>
retcode = SQLPutData(hStmt, (SQLPOINTER)buffer, buflen);
...
retcode = SQLParamData(hStmt, &ValuePtr); >>>> after diag gives
SQL0423N



Mon, 18 Jul 2005 09:55:47 GMT
 
 [ 1 post ] 

 Relevant Pages 

1. SQLPutData, SQLParamData ...

2. Help: ODBC, SQLParamData, SQLPutData (long ODBCSPY trace)

3. SQLPutData() returns SQL_SUCCESS but no record added to table

4. SQLPutData() returns SQL_SUCCESS but no record added to table

5. SQLPutData() returns SQL_SUCCESS but no record added to table

6. SQL0423N with JBC and BLOB

7. !HELP! ODBC and SQLParamData problem with Sybase

8. ODBC: SQLPutData out of memory after 5MB?

9. Blob using SQLPutData: getting Function Sequence Error

10. SQLPutData code sample?

11. SQLPutData and MSVC++ 4.2, please help

12. SQLPutData problem


 
Powered by phpBB® Forum Software